...

資料はこちらから

by user

on
Category: Documents
4

views

Report

Comments

Transcript

資料はこちらから
横浜市立大学様
~ 次世代シーケンサ用データ解析ソフトウェア ~
GenomeJack3.2説明資料
2015年10月2日
三菱スペース・ソフトウエア株式会社
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
1
GenomeJackとは?
• NGSデータ解析~データビューイングまでGUI操作だけで行うこと
ができるシステムです
GenomeJack Browser (フリーウェア)
(ユーザー様PC)
 解析ジョブ起動
 データビューイング
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
2
GenomeJack Analysis
(Linuxサーバー)
 解析ジョブ実行
 データ保管
GenomeJackで何ができるか?
• FASTQファイルのアップロード(インポート)、一次解析、二次解析、
データビューイングというNGSデータ解析の全ての処理
• 研究所内(グループ内)でのデータ共有、一元管理(バックアップ)
• GenomeJack Analysis以外で解析したデータのビューイング
• GenomeJack Analysisで解析したデータを、GenomeJack
Browserごと他の機関の方に配布できます(GenomeJack
Browserはフリーです!)
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
3
インストール方法
• Webブラウザで以下のURLにアクセスして下さい
http://163.212.165.218:9090/GJAnalysis
• 画面の指示に従って、PCのスペックに合わせたパッケージをダウン
ロードして下さい
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
4
ライセンスキーの取得
• 初回起動時のみ、PCごとのライセンスキー登録の手続きが必要で
す。
• 画面の指示に従ってライセンスを登録下さい。
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
5
ログイン
• ダウンロードしたパッケージをダブルクリックして起動するとログイン
画面が開きます
• アカウント名とパスワードを入力して下さい(アカウント名とパスワー
ドは別途ご連絡します)
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
6
GenomeJack Analysisの操作方法
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
7
解析の流れ
1. ゲノムが選択されていない(トラック等が全く表示されていない)場合、ゲノムを選択します
([File] > [Select Genome])
2. 画面左のリソースツリーにファイルをアップロードorインポートする
3. リソースツリー上でファイルを右クリックして、実行したい解析ツールを選択する
→2つ以上のファイルを用いる解析(リードペア、ケースコントロール等)では、該当ファイ
ルを複数選択して右クリックして下さい
4. 解析パラメーターを選択して、解析を実行する
5. 解析が終了したら、結果ファイルを右側の画面にドラッグアンドドロップすると、結果を確
認できます
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
8
サーバリソースダイアログの見方
•
ダイアログメニュー
サーバ上のリソース情報(ゲノム、解析デー
タ、ジョブ)を管理するダイアログで、以下の
操作を行える
ディレクトリツリー
解析メニュー
Job List表示ボタン
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
9
–
–
–
–
–
ユーザ、グループの管理
ゲノム、解析データの登録、削除
データのアクセス権設定
解析ジョブの実行
ジョブの管理
フォルダの作成とデータアクセス権設定
•
•
•
フォルダを追加するフォルダを選択して右クリック
ポップアップメニューの[New Folder…]を左クリック
Privilegeでアクセス権を設定して[OK]ボタンをクリック
グループ毎に
アクセス権を設定
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
10
ゲノムデータを登録する
•
hg19以外のゲノムを使いたいとき
– GenomeJack Analysis では、ユーザが所有しているゲノムデータをア
ップロードすることが可能です。
– [File] > [Upload Genome…]メニューを選択してUpload Genomeダイア
ログを表示します
– ゲノムデータとゲノムデータファイルを設定して[OK]ボタンを左クリック
します
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
11
11
ローカルのデータをサーバにアップロードする
•
•
•
•
データをインポートするフォルダを選択して右クリック
[Upload] > [ファイル形式]をクリック
アップロードするファイルを選択して[開く]ボタンをクリック
[Submit Job]ボタンをクリック
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
12
サーバ上のデータをインポートする
•
•
•
•
•
データをインポートするフォルダを選択して右クリック
[Import] > [ファイル形式]をクリック
インポートするファイルを選択して[>>]ボタンをクリック
[OK]ボタンをクリック
[Submit Job]ボタンをクリック
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
13
サーバからデータをダウンロードする
•
•
•
ダウンロードする解析データを
選択して右クリック
[Properties/Download…]を
左クリック
データダイアログが開くので
[Download]ボタンをクリックして
必要なデータをダウンロードする
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
14
サーバ上で解析を実行する
•
•
•
リソースツリー上でデータを選択して、右クリ
ック
実行したい解析を左クリック
Setup Input / Output Resourcesで必要なオ
プションを選択して[Submit Job]ボタンをクリッ
ク
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
15
(参考)GenomeJackがサポートしている解析ツール
•
NGS解析全般に対応しています([Analysis]→[Show All Tools]から全ツール一
覧を参照できます)
–
–
–
–
–
–
•
•
QC
マッピング
RNA-Seq
ChIP-Seq
SNP, INDEL detect
Annotation
独自のツールを追加することも可能です
フィードバックお待ちしています!
「このツールをGenomeJackで使いたい!」→最後のページの技術窓口までリ
クエスト下さい
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
16
ジョブの一覧表示と管理
•
•
•
[Job List]ボタンをクリックする
登録したジョブの一覧表示とステータスの確認が可能
実行中のジョブの停止、キャンセルも可能
ジョブの停止
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
17
GenomeJack Browserの操作方法
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
18
リファレンスゲノムを変更する
•
•
[File] > [Select Genome…] メニューを左クリック
Select Genomeダイアログで表示したいゲノムデータを
プルダウンメニューから選択して、「OK」ボタンを左クリック
ゲノム種別を選択
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
19
ローカルのデータを表示する
•
•
•
[File] > [Import Track Data]メニューを左クリック
ファイル選択ダイアログで、トラックデータファイルを設定して、
「開く」ボタンを左クリック
トラックデータ登録ダイアログで登録データを設定して、「OK」ボタンを左クリ
ック
Data format
BED/BEDGRAPH
WIG
GTF、GFF
SAM/BAM
VCF
TSV、TXT
MFA
BigWig
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
20
表示領域を変更する
•
表示領域の変更を行う場合には、マウスでドラッグする方法と、
コントロールバーのスクロールボタンを使用する方法が利用可能
スクロールボタンと
拡大縮小ボタンで操作
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
21
染色体ドロップダウンと、領域指定テキスト
ボックスへの数値直接入力で操作
参考)トラックデータの見方の一例
規定以上離れているリードペアの表示
リシーケンスリードトラックの表示例
ペアがアンマップなリードのみ色づけ
Insertion候補領域
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
22
BAMフラグによるDeletion候補領域表示
ペアリードの染色体によって
色付けが可能
Rearrangement候補領域
データを検索する
•
•
検索テキストに検索キーワードを入力して「Enter」キーを押す
検索キーワードに一致する対象データが表示される
検索キーワードを入力
検索可能なデータは、データ登録時に
Indexが作成された項目
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
23
詳細情報を表示する
•
•
詳細情報を表示するデータを左ダブルクリックする
詳細情報を表示したダイアログが表示される
リンククリックで登録された
公共DBにアクセス可能
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
24
ブックマークを利用する
•
•
•
記録しておきたい領域を表示し、 ボタンをクリック
Add Bookmark ダイアログでブックマーク名を入力して、
「OK」ボタンを左クリック
メニューの[Bookmark]から登録したブックマークを呼び出せるようになる
ブックマーク名を入力
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
25
データの表示方法を調整する
•
•
•
表示設定を変更したいトラックのラベルを左クリック
Configure The Track Settings ダイアログが表示される
色や高さ等の情報を更新して[OK]ボタンを押すと変更が反映される
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
26
データを出力する
•
•
•
[File] > [Export Tracks Data…] メニューを左クリック
Export Sequence Dataダイアログで出力するトラックを選択する
Export Fileダイアログで出力形式を選択して保存を実行する
出力するトラックを選択する
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
27
一覧表示してデータを絞り込む
•
•
•
•
[View] > [Show Table View] > [表示させたいトラック]を左クリック
Table Viewダイアログの[Edit]ボタンをクリック
Feature Filter Settings ダイアログでフィルタ条件を設定して[+]ボタンをク
リックし、フィルタ条件を確定させて[OK]をクリックする
フィルタが実行されてテーブルのデータが絞り込まれる
現在設定中のフィルタ条件
が表示される。
フィルタ条件を設定して
[+]ボタンを押す。
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
28
外部アプリケーションからアクセスする
•
•
•
外部アプリケーションに次のURL を設定する
http://[machine]:AAA/goto?genome=BBB&chr=CCC&start=DDD&end=EEE&trac
kId=FFF
– [machine]:GenomeJack が起動されているマシン名。外部アプリケーションと
同じPC上の場合、localhost でもアクセスすることができます。
– AAA :ポート番号
– BBB :ゲノム名
– CCC:参照配列名
– DDD:表示領域の開始位置
– EEE:表示領域の終了位置
– FFF:トラックのID(非表示の場合に表示に変更)
例:http://localhost:60152/goto?chr=1&start=1&end=1000
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
29
Webサイトなど
• GenomeJack Webサイト
http://genomejack.net
GenomeJack Browserの無料配布
、FAQ等
• twitterアカウント
最新情報をtwitterで配信しています!@genomejack
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
30
30
お問い合わせ先
<営業窓口>
三菱スペース・ソフトウエア株式会社
営業本部 第二営業部 谷戸 隆史
TEL:06-4961-8825
Mail:[email protected]
<技術的なお問い合わせ>
関西事業部 バイオメディカルインフォマティクス開発室 技術課
TEL:06-4961-8861
Mail:[email protected]
Copyright 2015 MITSUBISHI SPACE SOFTWARE CO., LTD. All Rights Reserved
31
31
Fly UP