...

OpticStudio 16.5

by user

on
Category: Documents
52

views

Report

Comments

Transcript

OpticStudio 16.5
リリース ノート
2016 年 10 月 18 日
1 目次
2
概要....................................................................................................................................................................................... 3
3
ライセンスの適用 ............................................................................................................................................................. 4
4
5
6
3.1
2 段階の手順によるソフトキー ライセンスの移行 (すべてのバージョン) .......................................... 4
3.2
ライセンスの自動更新 (すべてのバージョン) .............................................................................................. 5
3.3
新しいハードキー テクノロジー (すべてのバージョン) .............................................................................. 6
解析....................................................................................................................................................................................... 7
4.1
ノンシーケンシャル ジオメトリ MTF の計算 (PREMIUM および PROFESSIONAL) ......................... 7
4.2
ZRD ファイルの固定光線に適用するフィルタ文字列 (PREMIUM および PROFESSIONAL) ..... 8
4.3
レイアウトで固定光線に適用するフィルタ文字列 (PREMIUM および PROFESSIONAL) ............ 9
4.4
フォトルミネッセンス機能の強化 (PREMIUM)............................................................................................ 10
4.5
[光束と波長の比較] (Flux vs. Wavelength) でのルーメン出力のサポート (PREMIUM および PR
OFESSIONAL) ....................................................................................................................................................... 12
4.6
ホイヘンス計算でのユーザーによる位相基準の制御 (すべてのバージョン) ............................... 13
各種ツール ...................................................................................................................................................................... 15
5.1
機械的半径のCADエクスポート (PREMIUM および PROFESSIONAL)........................................... 15
5.2
レイアウト ウィンドウの新しい更新設定 (すべてのバージョン) .......................................................... 16
5.3
レンズ データ エディタの新しい描画解像度 (すべてのバージョン) .................................................. 17
5.4
マンジャン ミラーのノンシーケンシャルへの変換 (PREMIUM および PROFESSIONAL)........... 17
最適化 ............................................................................................................................................................................... 17
6.1
7
8
有効半径のオペランド (PREMIUM および PROFESSIONAL) .............................................................. 17
サード パーティのカタログ ......................................................................................................................................... 18
7.1
BERNHARD HALLE の新規在庫レンズ カタログ (すべてのバージョン) ......................................... 18
7.2
Nikon の新規材料カタログ (すべてのバージョン).................................................................................... 19
7.3
HOYA の材料カタログの更新 (すべてのバージョン) ............................................................................. 19
7.4
NHG の材料カタログの更新 (すべてのバージョン) ................................................................................ 19
7.5
Ohara の材料カタログの更新 (すべてのバージョン) ............................................................................. 20
7.6
Zeon の材料カタログの更新 (すべてのバージョン) ............................................................................... 20
プログラミング ................................................................................................................................................................. 20
8.1
ZOS-API の対話型拡張機能 (PREMIUM および PROFESSIONAL) ................................................ 20
8.2
ZOS-APIの ZRDREADER ツールの改善 (PREMIUM および PROFESSIONAL) .......................... 22
Copyright ©Zemax, LLC 2016. All Rights Reserved.
2
9
ユーザー インターフェイスおよび操作性 .............................................................................................................. 23
9.1
解析ウィンドウの更新 (すべてのバージョン) ............................................................................................ 23
9.2
半径基準の更新 (すべてのバージョン) ...................................................................................................... 23
9.3
スレッディング アーキテクチャの改良 (すべてのバージョン) .............................................................. 23
10 バグ修正 .......................................................................................................................................................................... 24
2 概要
OpticStudio 16.5 は、光学系と照明を設計するうえで技術者、研究者、科学者、学生に必須となるソフトウェア
の最新バージョンです。当社の最新リリースでは、迷光とフォトルミネッセンスを扱うための新機能と、OpticStud
io を迅速、容易に使用できるようにする操作性の改善を導入しています。この内容は以下のとおりです。
光線追跡 - OpticStudio 16.5 では、各種の迷光解析ツールを新たに追加しているので、これらのツールを使用
して光学系に不要な光線を特定して遮断できます。これらの新しいツールで迷光解析を容易にして、一貫性と
正確さに優れた結果を迅速に得ることができます。たとえば、機械的取り付け部の影響を直接測定して定量化
し、重要な光線を迅速に切り分けたうえで、新しい ZRD フィルタ設定を使用して、調査対象とする特定の光線を
光線データベースで選択できます。また、新しいフィルタ文字列を指定して光線の本数を制限することで、レイア
ウトとシェーデッド モデルのシステム ビューアに迷光の光路を一貫性のある方法で迅速に表示することもでき
ます。
フォトルミネッセンス - 燐光材料と蛍光材料のモデル化機能を OpticStudio 15 で導入していました。OpticStudi
o 16.5 ではこの機能を拡張して、より幅広い燐光材料と蛍光材料をモデル化できるようにしています。また、新
しいフォトルミネッセンス ミー粒子の密度設定を使用して、角度均一性の向上と角度によって色が変化する効
果の低減を図っています。フォトルミネッセンスの平均自由光路長の設定で、燐光材料と蛍光材料の色温度を
変更することもできます。
操作性 - OpticStudio 16.5 では、解析ウィンドウのレンダリング速度を速くすることで、データの可視性を改善し
ています。エディタで設定を変更した場合でも、その結果がレイアウト プロットとシェーデッド モデルに迅速に表
示されます。さらに、2 段階の簡単な手順を実行するだけで、2 台のコンピュータの間でソフト キー ライセンスを
移行できます。また、OpticStudio 16.5 では、新たに Bernhard Halle レンズカタログと Nikon 材料カタログを追
加し、NHG、Ohara、Zeon、Hoya の各材料カタログを更新しています。
OpticStudio には、Standard、Professional、および Premium の各バージョンが用意されています。ここでは、機
能ごとにそれを利用できるバージョンを注記しています。OpticStudio の各バージョンの詳細については当社の
Web サイトをご覧ください。また、アップグレードについては最寄りの営業担当までお問い合わせください。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
3
3 ライセンスの適用
3.1 2 段階の手順によるソフトキー ライセンスの移行 (すべてのバージョン)
2 台のコンピュータ間でソフトキー ライセンスを移行できるように、簡潔なワークフローを導入しています。これま
では、シングル ユーザー ソフトキー ライセンスの移行に 3 段階の手順が必要なうえ、そのライセンスがないコン
ピュータ側で移行プロセスを開始する必要がありました。新しい移行プロセスは 2 段階の手順に簡素化されてい
ます。
1.
ライセンスが現在適用されているコンピュータからライセンスをプッシュ処理で送り出します。
2.
そのライセンスを新しいコンピュータに適用します。
この 1 番目の手順を開始するには、ライセンスが現在置かれているコンピュータで Zemax License Manager (ZL
M) を起動します。ZLM は <C:\Program Files\Zemax OpticStudio> または<C:\Program Files\Zemax License Ma
nager> から起動できます。[ライセンス情報] (License Information) タブに移動し、もう 1 台のコンピュータに移行
するライセンスを探し出します。
[移行] (Transfer Away) ボタンをクリックします。電子メール アドレスの入力を求められます。この指定したアドレ
スにライセンス移行コードが送信されるので、新しいコンピュータ上でこの移行コードを容易に使用できます。
現在のコンピュータからソフトキー ライセンスが削除され、この移行コードが生成されます。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
4
2 番目の手順で、新しいコンピュータにライセンスを適用します。この手順を実行するには、新しいコンピュータで
Zemax License Manager を起動します。[新しいキー] (New Key) タブに移動し、移行コードを該当のフィールドに
貼り付けます。
[ライセンスの適用] (Apply License) ボタンをクリックすると、新しいコンピュータにライセンスが適用されます。
ソフトキー ライセンスの購入に関する質問やハードキー ライセンスからソフトキー ライセンスへの交換について
は、Zemax の営業担当 ([email protected]) までお問い合わせください。
3.2 ライセンスの自動更新 (すべてのバージョン)
OpticStudio のライセンス ステータスとメンテナンス プランの有効期限が自動的に更新されるようになり、最新の
ライセンス情報と OpticStudio サポート担当へのアクセスを確保できるようになっています。
OpticStudio のこれまでのバージョンでは、ライセンスを変更したときにローカルのライセンス情報を手動で更新す
る必要がありました。ライセンスの変更とは、年間メンテナンス プラン (またはサポート プラン) の更新、OpticStud
io の別のバージョンへのアップグレード、ネットワーク ライセンスへのシートの追加などをいいます。現在は、これ
らの変更が Zemax License Manager で自動的に検出され、ライセンス情報が自動的に更新されるようになってい
ます。更新の有無が Zemax License Manager で毎日または指定の頻度で確認されます。この頻度は、OpticStud
io の [プロジェクト環境設定] (Project Preferences) の [更新を確認] (Check for Updates) の設定で指定します。
このデフォルトの設定は、次に示すように [毎日] (Every Day) です。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
5
[更新を確認] (Check for Updates) の設定は、OpticStudio の [設定] (Setup) タブ→ [プロジェクト環境設
定] (Project Preferences) → [全般] (General) にあります。ライセンス情報を確認するには OpticStudio
の [ヘルプ] (Help) タブ→ [Zemax について] (About) を選択します。
3.3 新しいハードキー テクノロジー (すべてのバージョン)
OpticStudio 16.5 では、新たに緑色 (シングル ユーザー) または赤色 (ネットワーク ライセンス) のセンチネル ハ
ードキー ライセンスを導入しています。これらの新しいキーには、従来の黒いハードキー テクノロジーをはるかに
上回る利点があります。
これらの緑色または赤色のハードキーにはドライバが組み込まれているので、インストール プロセスが簡素化さ
れています。また、新しい暗号化テクノロジーによってセキュリティが強化されています。
Zemax License Manager では、新しいハードキーがソフトキーと同じ形式で表示されます。つまり、ネットワークで
利用できるすべてのライセンスとローカルでインストールされているすべてのライセンスを同じアプリケーションで
管理できます。
最後に、これらの新しいキーは物理的な長さが 25% 短くなっているので、保管が容易なほか、コンピュータの US
B ポートを破損する可能性が少なくなっています。
新しいハードキー ライセンスの購入に関する質問や、従来の黒いハードキー ライセンスを新しい緑色または赤色
のハードキー ライセンスに交換する方法については、Zemax の営業担当 ([email protected]) までお問い合わせ
ください。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
6
4 解析
4.1 ノンシーケンシャル ジオメトリ MTF の計算 (PREMIUM および PROFESSIONAL)
変調伝達関数 (MTF) は、レンズ光学系の性能を記述するために広く使用されている仕様です。OpticStudio の
これまでのリリースでは、シーケンシャル モードでのみ MTF を計算でき、ノンシーケンシャル モードでは計算で
きませんでした。
OpticStudio 16.5 では、ノンシーケンシャル モードのディテクタ (矩形) でジオメトリ MTF を新たに計算できるよ
うにしています。この計算では、ディテクタ (矩形) 上での放射照度の空間分布を使用して、このディテクタの X
軸方向と Y 軸方向のジオメトリ MTF を求めます。ノンシーケンシャル ジオメトリ MTF の計算では、ディテクタに
到達するすべてのノンシーケンシャル光線を使用します。つまり、光線の分割と散乱で、迷光と機械部品による
効果が考慮されます。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
7
ディテクタ (矩形) を表示したディテクタ ビューアの [表示方法] (Show As) に、ノンシーケンシャル ジオメトリ MT
F の計算機能が用意されています。フィルタ設定を使用することで、ノンシーケンシャル ジオメトリ MTF の計算
結果をシーケンシャル ジオメトリ MTF の計算結果と比較することもできます。1 つの光源からの光線をフィルタ
設定で一度に抽出できます。このフィルタはディテクタ ビューアで設定します。
MTF 計算の最大空間周波数を指定することもできます。この最大空間周波数を 0 に設定すると、ピクセル サ
イズに基づくナイキスト周波数が最大空間周波数になります。X 方向と Y 方向でピクセル寸法が異なる場合
は、低いほうのナイキスト周波数が使用されます。
4.2 ZRD ファイルの固定光線に適用するフィルタ文字列
(PREMIUM および PROFESSI
ONAL)
ノンシーケンシャル光線追跡の際に、以降の解析で使用できるように光線の交差データを Zemax 光線データベ
ース (ZRD) ファイルに保存できます。光線追跡は 1 回のみとして、得られたデータを ZRD ファイルに保存し、そ
のデータに対してさまざまな解析を実行するほうが便利です。
ZRD ファイルは多くの光線を収めているのできわめて大きいサイズになることが普通です。したがって、光線デー
タベース ビューアや光路解析ツールで ZRD ファイルを解析することは困難です。その解決方法として、特定の条
件に合致する光線のみを抽出するフィルタ文字列を使用します。特定の光線に関連するデータを表示する前に、
その光線が合致する必要のある「テスト」をフィルタ文字列で定義します。フィルタ文字列のシンタックスは、光線
のセグメントがオブジェクトに到達したかどうかを示すフラグ、および到達している場合にそのオブジェクトとの間
で発生したイベントが反射、屈折、散乱、回折、ゴースト反射のいずれであるかを示すフラグとの間で実行する論
理演算で構成されます。
OpticStudio 16.5 では、解析対象とする光路と正確な光線本数の両方を選択できるフィルタ文字列を新たに追加
しています。このシンタックスは次のとおりです。
{#(フィルタ文字列で指定する光線の本数)} (複合フィルタ文字列)
たとえば、フィルタ文字列として {#50} (H5 & M6) を指定すると、オブジェクト 5 に到達してオブジェクト 6 には到達
しない 50 本の光線のデータが表示されます。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
8
ZRD の中でこの条件に合致する光線が 50 本未満の場合、この新しいフィルタ文字列には何の効果もありませ
ん。光路解析ツールと光線データベース ビューアに表示する光線の本数を制限する場合に、このフィルタ文字列
が特に効果的です。
4.3 レイアウトで固定光線に適用するフィルタ文字列 (PREMIUM および PROFESSIONA
L)
OpticStudio 16.5 では、3D レイアウト ビューアとシェーデッド モデル ビューアに特定の光線の光路を迅速、効率
的に表示するための文字列を新たに追加しています(フィルタ文字列の詳細は 4.2 節を参照してください)。光線の
散乱と分割を有効にすると 3D レイアウト ビューアとシェーデッド モデル ビューアが煩雑な表示になることが多い
ので、その場合はこの機能がきわめて効果的です。
OpticStudio のこれまでのリリースでは、レイアウト光線の本数をフィルタ文字列とは別に指定していました。した
がって、フィルタ文字列では、3D レイアウト ビューアとシェーデッド モデル ビューアに描画する光線の本数を制限
できましたが、表示する光線の本数は指定できませんでした。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
9
OpticStudio 16.5 の新しいフィルタ文字列では、3D レイアウト ビューアとシェーデッド モデル ビューアに表示する
光路と正確な光線本数の両方を指定できます。このシンタックスは次のとおりです。
{#(フィルタ文字列で指定する光線の本数)} (複合フィルタ文字列)
たとえば、フィルタ文字列として {#50} (H5 & M6) を指定すると、オブジェクト 5 に到達してオブジェクト 6 には到達
しない 50 本の光線が描画されます。
この条件に合致する光線が 50 本未満の場合、この新しいフィルタ文字列はシェーデッド モデル ビューアでは何
の効果も示しません。
4.4 フォトルミネッセンス機能の強化 (PREMIUM)
フォトルミネッセンスとは、光学的な活性を持つ特定の分子が光を吸収してダウンコンバートし、吸収した光よりも
長い波長の光を再放出する特性です。OpticStudio では、スペクトル ファイルを使用してフォトルミネッセンスをモ
デル化します。スペクトル ファイルは、フォトルミネッセンスと散乱イベントの発生確率を求めるために必要なスペ
クトル データと平均自由光路長の計算値を収めたファイルです。このフォトルミネッセンスのモデルは OpticStudi
o 15.0 で導入された機能で、ノンシーケンシャルの [オブジェクト プロパティ] (Object Properties) の [体積特性]
(Volume Physics) で設定します。このモデルは、平均自由光路長が波長に依存しないミー散乱モデルと密接に関
連しています。
OpticStudio 16.5 では、このフォトルミネッセンス モデルの機能強化を進め、ミー散乱モデルと波長シフトから切り
離したモデルとしています。これにより、これまで以上に幅広い燐光材料と蛍光材料を正確にシミュレートできるよ
うになっています。このような材料として、散乱を発生しない親材料の中でルミネッセンスを発生する材料がありま
す。この新しいフォトルミネッセンス機能の平均自由光路長設定を使用して、燐光材料と蛍光材料の色温度を変
更することもできます。また、ミー粒子密度に対する新しい設定機能を使用して、角度均一性の向上と角度によっ
て色が変化する効果の低減を図ることもできます。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
10
ノンシーケンシャル モードでオブジェクトに新しいフォトルミネッセンス モデルを適用するには、[オブジェクト プロ
パティ] (Object Properties) を開き、[体積特性] (Volume Physics) タブで [蛍光体と蛍光] (Phosphors and Fluore
scence) ラジオ ボタンを選択します。フォトルミネッセンス モデルには基本モデルと標準モデルの 2 種類がありま
す。基本モデルは OpticStudio 15.0 で導入されたオリジナルのフォトルミネッセンス モデルであり、下位互換性の
サポートのみを目的として用意されています。標準モデルには新しい機能強化が追加されているので、あらゆる
状況で標準モデルの使用をお勧めします。
[蛍光体と蛍光] (Phosphors and Fluorescence) のセクションは、体積の燐光の振る舞いを制御するセクションと蛍
光の振る舞いを制御するセクションの 2 つに分かれています。[フォトルミネッセンス データ] (Photoluminescence
Data) セクションには、[ミー散乱] (Mie Scattering) 設定から切り離した [平均自由光路長] (Mean Free Path) の設
定があります。この設定では、フォトルミネッセンスが発生する平均光路長をレンズ ユニットで指定します。この値
は波長に依存しません。同様に、[ミー散乱] (Mie Scattering) には、独立した [平均自由光路長] (Mean Free Pat
h) と [粒子密度] (Particle Density) の設定があります。この [平均自由光路長] (Mean Free Path) の設定では、
散乱が発生する平均光路長をレンズ ユニットで指定します。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
11
[粒子密度] (Particle Density) の値に基づいて平均光路長を計算することもできます。フォトルミネッセンスとミー
散乱それぞれで平均光路長を独立した設定にしたことで、散乱発生源と非散乱発生源のどちらを親材料としてい
ても、そこに埋め込まれた燐光体と蛍光体をこれまで以上に詳しくモデル化できるようになりました。
フォトルミネッセンス材料の中を光線が伝搬すると、発生する現象として 4 種類が考えられます。すなわち、この
ような光線では、ミー散乱、フォトルミネッセンス、再放射のない吸収のいずれかが発生するか、何も発生しませ
ん。これらのうち、どの現象が発生するかは、以下のフロー チャートで判断できます。
ここで、次の式が成立します。
Ltot は、平均自由光路長の合計です。
LMie は、ミー散乱の平均自由光路長です。
LPL は、フォトルミネッセンスの平均自由光路長です。
A は、入力波長λ
での吸収係数です。
散乱の種類は、0 から 1 の間で均一に発生する乱数 r を生成することで選択されます。r < Ltot/LPL であれば、光
線にはフォトルミネッセンスが発生します。それ以外では、ミー散乱が発生します。入力波長での励起スペクトル
値がゼロでない場合は、光子が再放射されます。この場合、波長は放射スペクトルからランダムに得られます。
励起スペクトル値がゼロの場合は、非放射チャネルで光子が失われます。この場合は光線が終端します。
光線にフォトルミネッセンスが発生して終端しなかった場合は、入射光線の方向に関係なく、全球方向にランダム
に光線が再放射されます。
光線にミー散乱が発生した場合、光線が特定の方向に散乱する確率はランダムではなく、ミーのパラメータによ
って決まります。
4.5 [光束と波長の比較] (Flux vs. Wavelength) でのルーメン出力のサポート (PRE
MIUM および PROFESSIONAL)
[光束と波長の比較] (Flux vs. Wavelength) による解析で、データが放射測定単位 (ワット) と測光単位 (ルーメン)
で報告されるようになりました。これらの単位は、システム エクスプローラでの光源の単位の設定に基づいて自
動的に選択されます。
この新しい測光単位を使用するには、ノンシーケンシャル ファイルを開き、システム エクスプローラの [単位] (Un
its) セクションに移動して、[光源の単位] (Source Units) を [Lumens] に変更します。[解析] (Analyze) タブ→[光
線追跡解析] (Raytrace Analysis) で [光束と波長の比較] (Flux vs. Wavelength) ウィンドウを開きます。光束の単
位もルーメンになります。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
12
4.6 ホイヘンス計算でのユーザーによる位相基準の制御 (すべてのバージョン)
OpticStudio 16 では、ホイヘンス PSF の構成に球面ウェーブレット基準を新たに導入しました。この機能によって、
光線ベースの回折を計算できる光学系の範囲が大幅に広がりました。たとえば、ピクセルで構成した回折面やホ
ログラム面を扱うことができます。以下の左の図は、車のタコメーターの表示をエンコードしたコンピュータ生成ホ
ログラム (CGH) の位相マップで、右の図は、球面ウェーブレット基準を使用して得られたホイヘンス PSF の計算
結果です。
OpticStudio 16.5 では、さらに一歩踏み込んだ処理が可能です。ホイヘンス位相の基準を、平面、球面、または自
動から手動で選択できるようになっています。この設定は、システム エクスプローラの [詳細] (Advanced) セクシ
ョンにあります。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
13
[ホイヘンス積分の計算方法] (Method to Compute Huygens Integral) での選択により、ホイヘンス積分の計算で
射出瞳にどの位相基準を使用するかが決まります。この設定は、ホイヘンス PSF 解析による出力だけではなく、
部分的にホイヘンス積分に基づく他の計算にも影響します。このような計算として、ホイヘンス MTF、回折エンサ
ークルド エネルギー、ファイバー結合の解析などがあります。また、DENC、DENF、FICL、MTHA、MTHS、MTHT、
STRH など、いくつかの評価関数オペランドにも影響します(これらの中には、特定の設定でのみホイヘンス積分
を使用するものがあります)。
計算手法を [自動] (Auto) に設定すると、ホイヘンス積分の計算にどの位相基準を使用するかが OpticStudio 側
で制御されます。どの基準になるかは、像面から射出瞳までの距離、波長、および像のサイズが考慮されて決ま
ります。これがデフォルトの設定です。
計算手法を [平面を強制] (Force Planar) に設定すると、ホイヘンス積分の計算には必ず平面の位相基準が使用
されます。射出瞳から像面に伝播する平面波が使用され、像面上の点ごとに波面の影響度がコヒーレントに加算
されます。射出瞳から像面までの距離が短い光学系では、この基準を使用します。これは、球面の位相基準を使
用できないからです。
計算手法を [球面を強制] (Force Spherical) に設定すると、ホイヘンス積分の計算には必ず球面の位相基準が
使用されます。射出瞳から像面に伝播する球面波が使用され、像面上の点ごとに波面の影響度がコヒーレントに
加算されます。
システム エクスプローラの [アパチャー] (Aperture) セクションで [Afocal Image Space] (Afocal Image Space)
を選択している場合、[ホイヘンス積分の計算方法] (Method to Compute Huygens Integral) は自動的に [平面
を強制] (Force Planar) に設定されます。これは、アフォーカル結像光学系で使用できる基準は平面のみであ
るからです。
最後に、ホイヘンス積分の位相基準を制御するため、マルチコンフィグレーション エディタ オペランド MCHI を
追加しています。自動的に基準が設定されるようにするには 0、強制的に平面の基準を使用するには 1、強制
的に球面の基準を使用するには 2 をそれぞれ指定します。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
14
5 各種ツール
5.1 機械的半径のCADエクスポート (PREMIUM および PROFESSIONAL)
OpticStudio 16 では、回転対称面で使用する現実的な機械的半径を導入しています。これらの機械的半径に伴
い、レンズ データ エディタに [チップ ゾーン] (Chip Zone) と [機械的半径] (Mechanical Semi-Diameter) という 2
つの新しいパラメータを導入しています。
OpticStudio 16.5 では、機械的半径を設定した面を CAD にエクスポートできるようにこの機能を拡張しています。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
15
[有効半径] (Clear Semi-Diameter)、[チップ ゾーン] (Chip Zone)、および [機械的半径] (Mechanical Semi-Diamet
er) を設定したレンズを、広く使用されている CAD ファイルとしてエクスポートし、他のソフトウェア パッケージや機
械設計で使用できます。面やオブジェクトを OpticStudio から CAD ファイルにエクスポートするには、[ファイル] (F
ile) タブ → [CAD ファイル] (CAD Files) に移動します。
[有効半径] (Clear Semi-Diameter)、[チップ ゾーン] (Chip Zone)、および [機械的半径] (Mechanical Semi-Diame
ter) の詳細については、9.2 節を参照してください。
5.2 レイアウト ウィンドウの新しい更新設定 (すべてのバージョン)
レイアウト ビューアやシェーデッド モデル ビューアなどで光学系の表示を更新する際に、これまで以上に高速
な UI 応答が得られるように新しい設定を追加しました。この新しい設定では、エディタとレイアウト ウィンドウの
みが更新され、開いている他の解析ウィンドウでは再計算が実行されないので、光学系に発生した変更点を迅
速に確認できます。
この新しい設定を使用するには、[設定] (Setup) タブ → [プロジェクト環境設定] (Project Preferences) → [エディ
タ] (Editors) の設定に移動します。
[プロジェクト環境設定] (Project Preferences) の [自動更新] (Auto Update) 設定は、新しいレンズ ファイルにデ
フォルトの環境を設定します。この設定は、レンズ データ エディタ ツールバー、ノンシーケンシャル コンポーネン
ト エディタ ツールバー、マルチコンフィグレーション エディタ ツールバー、またはシステム エクスプローラにある
[更新] (Update) モードを変更することにより、開いているレンズ ファイル内でオーバーライドすることができま
す。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
16
5.3 レンズ データ エディタの新しい描画解像度 (すべてのバージョン)
シェーデッド モデル ビューアとレイアウト ビューアで個々のシーケンシャル面の解像度をカスタマイズできるよう
に、新しい設定を追加しました。この新しい設定である [描画解像度] (Drawing Resolution) は、レンズ データ エ
ディタの [面のプロパティ] (Surface Properties) の描画セクションにあります。この設定は、面を表示する際の解
像度を制御します。[標準] (Standard)、[中] (Medium)、[高] (High)、または [プレゼンテーション] (Presentation)
を選択できます。
5.4 マンジャン ミラーのノンシーケンシャルへの変換 (PREMIUM および PROFESSIONA
L)
OpticStudio には、NSC に変換するためのツールが用意されています。このツールでは、レンズ データ エディタ
にある一定範囲のシーケンシャル面を、ノンシーケンシャル コンポーネント面または新しいノンシーケンシャル
光学系に置いた 3D オブジェクトのグループに変換します。
この NSC への変換ツールは、シーケンシャルなマンジャン ミラー面をノンシーケンシャル オブジェクトに変換で
きるように拡張されています。この変換ツールは [ファイル] (File) タブにあります。
6 最適化
Copyright ©Zemax, LLC 2016. All Rights Reserved.
17
6.1 有効半径のオペランド (PREMIUM および PROFESSIONAL)
OpticStudio では、レンズ データ エディタで面の [有効半径] (Clear Semi-Diamieter) と [機械的半径] (Mechani
cal Semi-Diameter) の両方を使用して、エッジ厚、半径、サグ、体積、および質量を表示し、最適化できます。こ
のような柔軟性の向上により、コンストレインツや最適化を必要とする面やレンズの領域を選択できるようになっ
ています。
[有効半径] (Clear Semi-Diamieter) または [機械的半径] (Mechanical Semi-Diameter) を選択するには、メリッ
ト ファンクション エディタですべての径のオペランドに新規モード入力を使用します。OpticStudio のメリット ファ
ンクション エディタは、[最適化] (Optimize) タブから開くことができます。メリット ファンクション エディタの径の
オペランドを機械的半径の位置で評価するには、デフォルトのモード設定に 0 を使用します。有効半径のエッ
ジ位置でこのオペランドを評価するには、モード設定を 1 に変更します。
有効半径または機械的半径を選択するためのモード入力を指定できる最適化オペランドは以下のとおりです。


DMGT
DMLT



DMVA
CVOL
MNDT
直径がこれ以上大きくなってはならない値
直径として指定する必要がある値
シリンダ体積
直径と厚みの比率の最小値


XNEA
XXEA



BLTH
ETVA
ETGT
所定範囲にある空気の最大エッジ厚
ブランクの厚み
エッジ厚として指定する必要がある値
エッジ厚がこれ以上薄くなってはならない値


MXDT
MNET
直径と厚みの比率の最大値
エッジ厚の最小値


ETLT
TTVA
エッジ厚がこれ以上厚くなってはならない値
合計厚みとして指定する必要がある値



MXET
MNEG
MXEG
エッジ厚の最小値
ガラスの最小エッジ厚
ガラスの最大エッジ厚



TTGT
TTLT
FTLT
合計厚みがこれ以上薄くなってはならない値
合計厚みがこれ以上厚くなってはならない値
全厚みがこれ以上厚くなってはならない値


MNEA
MXEA
空気の最小エッジ厚
空気の最大エッジ厚


FTGT
STHI
全厚みがこれ以上薄くなってはならない値
面の厚み


XNET
XXET
所定範囲にあるエッジの最小厚
所定範囲にあるエッジの最大厚


SSAG
TMAS
面のサグ
合計質量


XNEG
XXEG
所定範囲にあるガラスの最小エッジ厚
所定範囲にあるガラスの最大エッジ厚

VOLU
エレメントの体積
直径がこれ以上小さくなってはならない値
所定範囲にある空気の最小エッジ厚
7 サード パーティのカタログ
7.1 BERNHARD HALLE の新規在庫レンズ カタログ (すべてのバージョン)
Bernhard Halle の新しい在庫レンズ カタログを追加しました。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
18
[ライブラリ] (Libraries) のリボン メニューにあるレンズ カタログにあります。
7.2 Nikon の新規材料カタログ (すべてのバージョン)
Nikon の新しい材料カタログを追加しました。
[ライブラリ] (Libraries) のリボン メニューにある材料カタログにあります。
7.3 HOYA の材料カタログの更新 (すべてのバージョン)
Hoya の更新済み材料カタログを追加しました。
[ライブラリ] (Libraries) のリボン メニューにある材料カタログにあります。
7.4 NHG の材料カタログの更新 (すべてのバージョン)
NHG の更新済み材料カタログを追加しました。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
19
[ライブラリ] (Libraries) のリボン メニューにある材料カタログにあります。
7.5 Ohara の材料カタログの更新 (すべてのバージョン)
Ohara の更新済み材料カタログを追加しました。
[ライブラリ] (Libraries) のリボン メニューにある材料カタログにあります。
7.6 Zeon の材料カタログの更新 (すべてのバージョン)
Zeon の新しい材料カタログを追加しました。
[ライブラリ] (Libraries) のリボン メニューにある材料カタログにあります。
8 プログラミング
8.1 ZOS-API の対話型拡張機能 (PREMIUM および PROFESSIONAL)
OpticStudio のアプリケーション プログラミング インターフェイス (ZOS-API) では、最新のソフトウェア テクノロジを
使用して OpticStudio への接続や OpticStudio のカスタマイズが可能です。
この新しい対話型拡張機能を使用すると、OpticStudio の開いているインスタンスに MATLAB や Python など
のスクリプト環境を接続できるので、ZOS-API コマンドのテストやデバッグで便利です。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
20
これにより、開いているレンズ ファイルで直接作業し、コマンドを行単位で実行して、その行による効果をリアルタ
イムで確認できます。
たとえば、OpticStudio の新しい対話型拡張機能に接続できる MATLAB 拡張機能を作成するには、[プログラミン
グ] (Programming) タブ → [MATLAB] → [対話型拡張機能] (Interactive Extension) に移動します。
OpticStudio に接続するボイラープレート コードを記述した MATLAB の新しいスクリプトが開きます。[プログラミン
グ] (Programming) タブ → [対話型拡張機能] (Interactive Extension) で OpticStudio の新しい対話型拡張機能ツ
ールを起動します。ダイアログ ボックスが開き、実行している OpticStudio のインスタンスのインスタンス ID が表
示されます。OpticStudio のインスタンスを 2 つ以上実行している場合は、そのうちの特定のインスタンス (1 また
は 2) に MATLAB を接続できます。
MATLAB でスクリプトを実行するには、[実行] (Run) ボタンをクリックするか、コマンド ウィンドウで目的のスクリプ
トを実行します。コマンド ウィンドウでインスタンス番号 (1 または 2) を括弧の中に記述することで、目的の Optic
Studio インスタンスを指定できます。タイプ ZOSAPI_Application のオブジェクトが関数から返され、ConnectionMo
de が Extension であることがプロパティに表示されます。OpticStudio 側では、対話型拡張機能が接続済みであ
ることが表示されます。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
21
8.2 ZOS-APIの ZRDREADER ツールの改善 (PREMIUM および PROFESSIONAL)
OpticStudio のアプリケーション プログラミング インターフェイス (ZOS-API) を使用して ZRD ファイルを処理で
きる高機能な手順を用意しました。この新たな手順では、C# の .dll ファイルを使用して光線データの複数のブ
ロックを MATLAB に一度に読み込みます。効率面で不利な while ループは使用しません。MATLAB で ZRD フ
ァイルを処理すると、これまで 30 分程度を要していましたが、この方法では C# による処理時間と同等で、通常
は 5 秒以下です。
以下に、MATLAB の ReadZRDFile コマンドの例を示します。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
22
9 ユーザー インターフェイスおよび操作性
9.1 解析ウィンドウの更新 (すべてのバージョン)
OpticStudio の解析ウィンドウで使用するグラフィック プラットフォームを更新しました。これにより、解析ウィンドウ
の処理速度と総合的な機能性が向上しています。
9.2 半径基準の更新 (すべてのバージョン)
ヘルプ ファイルと OpticStudio ユーザー インターフェイスですべての半径基準の記述を更新し、有効半径、チッ
プ ゾーン、および機械的半径の相違を明白にしました。
有効半径は、光線が通過する面の有効口径に対応しています。これまでは単に半径としていました。
チップ ゾーンは、面の上で有効半径の曲率に続く緩衝領域です。この領域はコーティング領域が終了する部分
となることが普通なので、厳しい公差は要求されません。
機械的半径は、面の取り付けエッジを定義するために使用します。この径を使用すると、平坦なフランジや曲げ
部分を持つフランジを容易にレンズに追加できます。
9.3 スレッディング アーキテクチャの改良 (すべてのバージョン)
重要な計算の多くで、スレッディング アーキテクチャを大幅に改善し、実行速度と堅牢性が向上しています。改良し
たスレッディング アーキテクチャは以下の領域で使用しています。







ローカル、ハンマー、およびグローバルの各最適化機能 (すべてのバージョン)
ホイヘンス PSF の計算 (すべてのバージョン)
FFT の計算 (すべてのバージョン)
物理光学伝搬 (PREMIUM および PROFESSIONAL)
公差解析 (すべてのバージョン)
ノンシーケンシャル光線追跡 (PREMIUM および PROFESSIONAL)
ノンシーケンシャル Lightning Trace (PREMIUM)
Copyright ©Zemax, LLC 2016. All Rights Reserved.
23
10 バグ修正
OpticStudio 16.5 では、以下のバグ修正を適用しています。
シーケンシャル光線追跡 :

平面ミラーまたは曲面ミラーの裏面にシーケンシャル光線が到達すると、システム チェック レポート
にエラーまたは警告のフラグが設定されるようになりました。光学系の各視野点と各波長を対象とし
て確認が実行されます。
解析 :




複数のコンフィグレーションに対してデータの加算または減算を実行した場合に偏光瞳マップの
透過率出力で発生していた問題を修正しました。
偏光していない入力から偏光結果を生成することを物理光学伝搬で指定すると、互いに直交する偏光
を持つ 2 本のビームが伝搬し、計算結果の平均値が返されます。この平均ビームを、シェーデッド モデ
ルとビーム ファイル ビューアで確認できるようになりました。
座標ブレーク面を使用して 90 度のティルトを設定した場合に物理光学伝搬で発生していた問題を修正
しました。なお、レンズ データ エディタで面に対して [ティルト/ディセンタ] (Tilt/Decenter) コントロールを
使用してティルトを設定した場合は、この問題は発生しません。
複数の波長を使用する光学系で視野に対する MTF (FFT、ホイヘンス、および幾何光学) 解析を実
行すると、波長エディタのテキスト出力には最後の波長による出力のみが表示されていましたが、
この問題を修正しました。
ノンシーケンシャル光線追跡 :

複屈折媒体の中を進む異常光線の吸収損失が、異常 (-E) 材料カタログに記述された透過率
データから正しく計算されるようになりました。
フォトルミネッセンス :



フォトルミネッセンスでダウンコンバートされる光線の初期波長の保存に関連する問題を修正しまし
た。
波長が 4 つ以下のスペクトルによるフォトルミネッセンスで発光スペクトルを補間すると発生してい
た問題を修正しました。
フォトルミネッセンス材料内部でミー散乱を経た光線の散乱分布が、そのミー散乱を経た最初の光線
の波長に正しく基づいた散乱にならず、現在散乱している光線の波長に正しく基づいた散乱にもなら
ない問題を修正しました。
プログラミング :

シーケンシャル モードで OpticStudio とユーザー定義の面との間で受け渡す FIXED_DATA5 構造体
を追加しました。この構造体を使用すると、すべてのパラメータ データをこの構造体の param ポインタ
で渡すことができ、xdata ポインタへのすべての参照が削除されます。
Copyright ©Zemax, LLC 2016. All Rights Reserved.
24
Fly UP