...

はじめの一歩

by user

on
Category: Documents
10

views

Report

Comments

Transcript

はじめの一歩
YellowIDE7対応
イエローソフトSH7084F CPUボード(YS7084-1用)
はじめの一歩
このマニュアルはYellowIDE7.07以上専用です。YellowIDE7.06以下のユーザ様は弊社ホームページにてアップデート
して下さい。
内容物(開発セットでご購入の場合)
ハード
□CPUボード
□電源ケーブル
□RS232Cケーブル
□「YS7084-1 ボードコンピュータ取り扱い説明書」
CD-ROM
□YellowIDE7.xx YCSH 4.0
マニュアル
□はじめの一歩(このマニュアル)
□YCシリーズCコンパイラ プログラマーズマニュアル
その他注意書きなどの書類が含まれている場合があります。
インストール
●YellowIDE7.xx YCSHと書かれたCD-ROMをドライブに挿入して下さい。自動的にインストーラ起動画面が開きますの
で、CコンパイラとYellowIDEの両方をインストールして下さい。
簡単なチュートリアル
タイマー割込みを使って一定間隔でメッセージを表示するという簡単な例を用いてYellowIDEの使い方を説明しま
す。
■YellowIDEの起動と初期設定
WindowsのスタートメニューからYellowIDEを起動して下さい。
次に、メニューの(ターミナル)->(設定)を開いて下さい。
ここで使用するパソコンのCOMポートを選択して下さい。(通信設定)をクリックするとボーレートなど変更できま
すが、最初の状態のままにしておいて下さい。これで、初期設定は終了です。
■ハードウェアの準備
①CPUボードのCN5(BOOTと書かれている)とパソコンをRS232Cケーブルで接続します。
②CPUボードの電源コネクタCN4に5V電源をつなぎます。
③4PのDIPスイッチを1番OFF 2番ON 3番OFF 4番ONにします。(アドバンスト内蔵ROM有効拡張モード)
以上でハードウェアの準備は終了です。
1
■プログラムの作成
まず、YellowIDEを起動します。そしてプロジェクトを作成します。メニューの(ファイル)->(プロジェクトの新
規作成)を選びます。そしてYellowIDEをインストールしたフォルダの下にあるSAMPLEというフォルダを開きます。
さらにPrj7084というフォルダを開きます。
ここで[ファイル名]のところに"test"と入力して(開く)ボタンをクリックします。
以上でプロジェクトが作成されました。
2
■プロジェクトにファイルを追加
プロジェクトウインドウの(追加)ボタンをクリックして下さい。ここでダイアログからTEST.Cを入力して下さい。
これでTEST.Cがプロジェクトに登録されました。登録したらプロジェクトウインドウのソースファイル名をダブル
クリックして下さい。そのソースファイルが開きます。
■ターゲットの設定
プロジェクトウインドウの(設定)ボタンをクリックして下さい。
CPUの種類をSH2にして下さい。
オブジェクトの形式をROM化(Sフォーマット)にして下さい。
3
次に"スタートアップ"のタグをクリックして下さい。
「□C言語のスタートアップルーチンを開く」をチェックした後に、スタートアップルーチンの(参照)ボタンをク
リックして"CSC7084.C"を選択して下さい。次に"セグメント定義"のタグをクリックして下さい。
下の方にあるボックスに次のように入力して下さい。
ROM番地 00000000---3FFFF RAM番地 2000000 ---201FFFF
そして、2つある(自動作成)のボタンを両方ともクリックして下さい。
4
次に"メモリマップ"のタグをクリックして下さい。 (イエロースコープをもっていない方はここは飛ばして下さい。)
[デバイス]の種類をROMにします。開始アドレスを0にします。終了アドレスを3FFFFにします。そして(追加)ボタ
ンをクリックして下さい。
以下同様に次のように設定します。
[デバイス]
[開始アドレス]
[終了アドレス]
RAM
2000000
201FFFF
入出力ポート
FFFF8000
FFFFFFFF
最後にグローバルアドレスマスクは"FFFFFFFF"のまま変更しません。
ここの設定は面倒なので保存しておくことができます。下の方にある(設定1保存)ボタンで保存名を"SH標準"に
して保存しておいて下さい。
以上でプロジェクトの設定は終了です。設定画面の一番下にある(OK)ボタンをクリックしてダイアログを閉じて
下さい。
■メイク
メイクはメニューから(プロジェクト)->(メイク)を選ぶか、スピードボタンの
します。次のメッセージが出てプログラムが完成です。
をクリックするか[F9]キーを押
ここに警告とエラーの数が表示されます。もしエラーがあればYIDEの下にあるエラーボックスにエラーメッセージ
が表示されます。
5
このエラーメッセージをダブルクリックすれば、ソースファイルの対応する行が反転表示されます。もしソースフ
ァイルが開いていなければ自動的に開いて、エラーの行を反転表示させます。
■プログラムをフラッシュROMに書き込んで実行させる。
今、完成したプログラムをターゲットのCPUのフラッシュROMに焼いて実行させてみましょう。
まず、CPUボードのリセットスイッチを2秒以上の長押しをしてください。隣のLEDが点灯するはずです。これでCPU
はブートモード(書き込みモード)で起動します。
次にスピードボタン
あるいは
のボタンをクリックして下さい。フラッシュROMライタが起動します。
[CPU情報ファイル]の(参照)ボタンをクリックしてSH7084(256K).FWIを選択します。
[COMポート]を選択します。
高速転送の[有効]をチェックして、[高速ボーレート]を38400、クロックを10000000にします。
最後に(書込み)ボタンをクリックすれば書き込みが始まります。
青いバーが最後まで伸びれば、書き込み終了です。終了したらフラッシュROMライタを閉じて下さい。
次に今書き込んだプログラムを実行させます。
まず、YellowIDEのターミナル画面をメニューの(ターミナル)→(表示)で開きます。
CPUボードのリセットスイッチを短く押してください。(LEDが消えます)
これで書き込んだプログラムが動作します。
6
黒い画面に、"Hello"と一定間隔で表示されます。
黒いターミナルウインドウはその都度、必ず閉じておいて下さい。ターミナルウインドウが開いたままだとフラッ
シュROMライタやイエロースコープが通信ポートを利用できないからです。
さて、これでプログラムの作成方法と実行の方法を修得しました。しかし直接ROMに焼いて実行させる方法はデバッ
グ中は何かと不便です。そこで他の実行方法も紹介します。
■RAMへダウンロードしてRAM上で実行させる
ROMより、RAMの方が書き込む速度は速いです。またフラッシュの寿命も気になりません。そのためプログラムをRAM
上で動作させる方法を紹介します。
最初にプログラムをRAMへ転送させる"ダウンローダ"と呼ばれるプログラムをCPUのフラッシュROMに書き込んでお
きます。これはデバッグの最初の一回だけやっておけば十分です。フラッシュに何も書き込まなければダウンローダ
はこのまま残ります。
最初に"ダウンローダ"のプログラムをCPUのフラッシュROMに書き込みます。リセットスイッチを長押し、ブートモ
ードにします。先ほどはフラッシュROMライタを起動するのにスピードボタンをクリックしていましたが、今回はメニ
ューから起動します。メニューの(ツール)→(フラッシュROMライタ(ファイル指定))で起動して下さい。違いは
書き込む途中で書き込むファイルを聞いてくることです。
(書込み)ボタンをクリックして下さい。消去終了後に書き込むファイルを入力するダイアログが開きます。
ここで、YellowIDEをインストールしたフォルダの下のLOADERというフォルダの下のSH7084というフォルダの中の
Loader.Sというファイルを指定して開きます。
以上でダウンローダの書き込みが終了しました。次に、先ほどのサンプルプログラムのプロジェクトに戻ります。
サンプルのプロジェクトに戻ったら、プロジェクトウインドウの[object]の▼のボタンをクリックして、"RAMへダ
ウンロード(S)"を選択して下さい。
7
そして、もう一度メイクします。
グラムが作成されました。
をクリックすればメイクが行われます。これで"RAMへダウンロード"用のプロ
そして、今度はこれをRAMへ転送して実行させます。
のボタンをクリックして下さい。
するとターミナルウインドウが開いて、次のように聞いてきます。
ここでCPUボードのリセットスイッチを短く押しリセットして下さい。黒いターミナルウインドウに"S-READER
START"と表示されるのを確認して(はい)ボタンをクリックして下さい。
プログラムが転送されます。プログラム転送終了後に"Hello"が一定間隔で表示されます。
ダウンローダは一度書き込めば残りますから、プログラムを修正する度にダウンローダを書き込む必要はありませ
ん。ただし、他のアプリケーションやイエロースコープのモニタなどをフラッシュに書き込むとダウンローダは消え
てしまいますから、その場合はもう一度、ダウンローダのファイルを開いて書き込みます。
この後どうするか
オプションのイエロースコープの使い方を簡単に説明した「イエロースコープはじめの一歩」をご覧下さい。イエロ
ースコープを使えば、プログラムをステップ実行させたり、プログラム実行途中の変数の値をウオッチすることがで
き、効率よくデバッグできます。未購入の方でもプログラムサイズが24KB以下であれば評価バージョンとして使用で
きます。
RLL(ROMリンクライブラリ)の機能を使えば、プログラムの転送時間を短縮でき、効率の良いプログラム開発ができま
す。RLL機能を使う場合はYellowIDEのメニューの[ヘルプ]→[ヘルプ]をご覧下さい。
「イエロースコープはじめの一歩」はYellowIDEをインストールしたフォルダの下の「マニュアル」フォルダにありま
す。
YellowIDEや、Cコンパイラのさらに詳しい説明は、YellowIDEのメニューの[ヘルプ]→[ヘルプ]でご覧いただけます。
サンプルプログラムは弊社ホームページの[ユーザ]⇒[サンプル&ライブラリ]のページにありますが、すべてのCPUで
用意しているわけではありません。
8
Fly UP